We are still observing some Authentication Errors. If you receive an Authentication Failure Please try to Login again.
We will continue to provide updates in this status page.
Posted Jun 12, 2025 - 12:10 MST
Update
We are seeing successful logins occurring. We will move this to monitoring once we determine users are successfully accessing the system.
Posted Jun 12, 2025 - 11:54 MST
Identified
Google Cloud is down globally. Many public services are currently affected.
Posted Jun 12, 2025 - 11:31 MST
Investigating
We are receiving numerous reports that users are unable to log in to web and mobile applications. The error "Invalid e-mail address or password" is displayed
Inbound and Outbound messaging appears to be unaffecfted.